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Description: 

This document is the second of two in describing the basics needed to know for 

designing Printed Circuit Boards (PCBs) with Altium Summer Designer 09. This 

document will describe the PCB layout aspect of designing PCBs. 
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Importing your Design from Schematic to Layout 
 

Before you start your layout, you need to have a complete and errorless schematic. We will use the 

example from the Altium_Schematic_Tutorial.pdf file to continue this portion of the design. Before 

proceeding, double check that each of your components in your design have the correct footprint. The 

design we will be building is seen in Figure 1 and Figure 2.  

 

 
Figure 1 Example Circuit (1/2) 

 

Figure 2: Example Circuit (2/2) 

Now that you have working design, import your design into your PCB layout document. Do this by 

clicking Design->Update PCB Document  <Filename>.PrjDoc. This can be seen in Figure 3. This will then 

pop up the Engineering Change Order Window seen in Figure 4. This window represents all of the new 

components or changes to your schematic that you would like to import into your PCB design. The first 

time this is done in a design, the list is quite long. It is suggested to only import into your design when 

you are ready to do some layout with parts of your schematic that are not expected to change. In most 

cases, this step is after you have finished schematic layout completely.  
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Figure 3: Updating your PCB Design 
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Figure 4: Summary for Layout Updates 

You can see in Figure 4, there is a list of all of the components, rooms and wires we created in our 

schematic. The other point to note is the 2 highlighted selections at the bottom. These represent a 

design room. Rooms are the PCB layout reflection of each schematic sheet. Sometimes a design calls for 

very specific or proximity or size in layout like in a power/feedback design or you might need to make a 

redundant layout for a second instantiation of a component. The room allows you do the necessary 

layout within the room and then you can move the room (or the grouped components) wherever on the 

PCB layout sheet you want them and copy the layout to an identical schematic room. Typically you will 

want to uncheck these so you do not have to deal with rooms. However, see appendix A.1 in 

Alitum_Schematic_Tutorial.pdf for more information about this. 

Go ahead and push Validate Changes first, then Execute Changes and then your PCB window will appear 

with your components on the bottom right corner of the black layout area as seen in Figure 5. If you did 
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not de-select the room choices, the components would appear as seen in Figure 6. If you want to 

remove a room, just click the red area around the components and push delete.  

 

Figure 5: New Components in the Layout Window 

 

Figure 6: New Components with Room Windows 

Now this is all you need to do to add new components to your PCB design. You can always add more, or 

change component footprints. When you do add new components or change them, they will show up in 

this same area. However, as previously stated, this step should not be pursued in parallel with schematic 

design. It should be done when you have a finished schematic.  

If you are having problems changing component footprints, in which they are not being updated on the 

PCB side, just delete the component on the PCB side and update once more.  

Layout Design 
The first important aspect to PCB design is to investigate your components. Make sure your footprints 

all seem to be what you expect them to be. If you have your components that you are building your 

board with, you can do actually print off the PCB layout with all of the footprints, and place your 

component over the printed layout paper and its corresponding footprint. Printing this gives a 1:1 ratio 

of what the board will become after manufacturing. The second point to notice about these 

components is there net label. It is important to label wires or just use Nets instead because the name 
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you provide will be represented on the Layout side. This can be seen in Figure 7.  You can see that the 

power pins are labeled with VCC, the ground pins GND, and so on. 

 

Figure 7: Nets Names on the PCB 

Lastly, you will notice some very faint white lines connected to different pads of components. This 

represents a connection that must be made during layout. Altium uses these to present you from 

making the wrong connections. Using these important techniques, it will make it very easy to perform 

an errorless layout. These reasons should also reinforce the idea of creating a robust, descriptive and 

errorless schematic before starting layout.  

Editing Component Properties 
Next we will look at the properties menu for components. By highlighting right clicking a single 

component you get a figure that looks like Figure 8. This window has many different options that you 

can change on your component. 
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Figure 8: Component Properties 

You can see you can change the font of the Designator text to be smaller or larger. You can change the 

layer you want the component or designator on. You can change the footprint even. Experiment by 

trying to change some of these parameters to see what it does to the component, but then undo all 

your changes before moving on. However, going through each component one by one to change font 

sizes or other parameters is painstaking. Instead, we can use the PCB inspector window to do this much 

faster. We will show this example using designator font sizes because they are defaulted to too large of 

a value. 

Go ahead and select all of you components by drag and clicking them to move them onto the black 

background. You will notice that all of the components have yellow lettering that matches the schematic 

designator (U1, R1,C1 etc.) from the schematic view. We are going to change all of these numbers to be 

a smaller font by utilizing the PCB inspector menu. To do that either highlight all of the yellow lettering, 
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or push sa, or choose select all from the top toolbar. Pushing the “s” key will show a window like that 

seen in Figure 9. 

 

Figure 9: The Select Menu 

After selecting all, the components will appear like the ones in Figure 10. Now we will want to just 

select the designators. On the top right side of the main toolbar, you will see three white boxes, the last 

with the word (ALL) inside of it. This has a drop down menu like that seen in Figure 11. Select the 

IsDesignator option. This will now only highlight your component designators like that seen in Figure 

12. If you ever need to deselect them, just return this toolbar to the (ALL) option. You can also just type 

the string IsDesignator into this window. If this window does not exist or has been closed you can right 

click the toolbar and select filter this will cause the toolbar to reappear.   

 

Figure 10: Highlighted Components 
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Figure 11: Select Menu Toolbar 

 

Figure 12: Highlighted Designators 

Now we will open the PCB Inspector menu by pressing F11 or click View->Workspace Panels->PCB->PCB 

Inspector. You can also do object filtering in this window. This will bring up a menu like that seen in 

Figure 13. In this window you can see there are a lot of options that you can change such as the layer all 

the designator appear on, the text height, font type, and etc. Go ahead and change the text height to 30 

mils. This will cause the text to appear like that seen in Figure 14. 
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Figure 13: PCB Inspector Menu 

 

Figure 14: Smaller Text Font 

This is technique is not just for the components themselves, but could also be used to change trace 

(wire) sizes, power pours, and many other things. Now that we have investigated the properties menu 

of components we will look into what the different layers mean.  
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The Different Layout Layers 
Before we start connecting components together, the last thing to note is the various colors you are 

seeing on the sheet as well as the bottom toolbar seen in Figure 15. These layers represent the 

different layers on your PCB. We will only deal with 2 Layer PCBs meaning, there are 2 physical layers we 

can create traces on (wires) to connect components.  

 

Figure 15: Navigating Layers Toolbar 

During the default view, you can see every layer. To show a specific layer, change to the layer by click it 

on the bottom toolbar and click shift->S. To navigate quickly between the layers you can do  

ctrl->shift->scroll wheel. A description of what each of the 6 basic layers can be seen in the table below: 

 

Name Color Description 

Top Layer Red Top layer of copper (traces, pads, and pours) 

Bottom Layer Blue Bottom layer of copper (traces, pads, and pours) 

Top Overlay Yellow Top Silkscreen, where any writing or designators are visible after 
manufacturing.  

Bottom Overlay Brown Bottom Silkscreen, where any writing or designators are visible after 
manufacturing. 

Top Solder Purple Top Solder mask, the non-conductive polymer covering for the copper 
layer.  

Bottom Solder Pink Bottom Solder mask, the non-conductive polymer covering for the 
copper layer. 

 

The Mechanical layers represent areas where physical changes to the board are present, like drilling 

holes. You will not need to worry about these layers unless you have more advanced designs that 

require it. 

 

Most of your work will be done on the top and bottom layers. You can add extra writing or pictures on 

the silkscreen. This is a good thing to do especially during your footprint design, so that you have a 

reference point on the footprint itself, such as a small designator or piece of text to signify VCC, GND, or 

etc.. Extra features will not be discussed in this document. 

Connecting Components together 
Now we discuss the physical layout of the PCB design. Go ahead and arrange your components in an 

efficient and meaningful way. To rotate your components, press Spacebar. My example can be seen 

below in Figure 16. Layout is all up to the designer. You might have specific factors you need to take 

into account during layout, such as area, trace lengths, or proximity. In general you want to reduce extra 

space and trace length and get components next to their correct components to match your schematic 

sheet. 
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Figure 16: Finished layout positioning 

Now that we have a positioning that works for us, we will connect the pads using traces. Either click p->t 

for place trace, or click Place->Interactive Routing. There will be crosshairs representing your cursor 

now, and place that over the pads you wish to connect. Click once to start and click a second time to 

place a segment of that trace, double click to end it. Always make traces turn at 45 degree angles, never 

90 degree angles. To change to 45 degree mode click shift->spacebar a few times will adding a trace to 

see the mode change. The layer you start on is default to the Top layer. To change layers and add traces 

to the bottom layer, select the bottom layer in the bottom toolbar and do the same as before.  My 

(almost) finished example is seen in Figure 17. A most important note though, is this layout was done 

by hand. NEVER use the Altium Auto route. This often introduces flaws into your design and should only 

be used by an experienced designer who knows how to set it up correctly.  

 

Figure 17: Almost Finished Layout 

You can see in my picture there are some funny looking circles over some traces. These are called Vias 

and are used to connect traces from the top layer to the bottom layer. To place a via, create a small 

trace from the component you wish to connect to the opposite layer, the click Place->Via and place the 

via over the trace. You will notice I have vias near every ground pin, and that I didn’t route any of the 

ground connections except for the first connection. This was done on purpose because we will be 

implementing a Pour, which creates a plane of copper on one layer that automatically connects any 

pads/vias of that net to each other.  
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Sometimes placing traces becomes irritating because of the automatic snapping of the trace shape or 

position of the components that Altium does. To change the snap grid, so it does this for smaller 

increments, right click and select Snap or select design. Change this to a value you like.   

Changing the Board Shape 
Now let us change our board size. To do this click Design->Board Shape->Redefine Board Shape. This is 

seen in Figure 18. Unless otherwise noted, the black outline of your layout represents your physical 

board size. Many manufacturers have limits to how large of an area this can be. For Advanced Linear 

(the PCB manufacturer), they require less than 60 sq. inches for their student special. You can also just 

move the board vertices from this menu. However, changing the shape is up to you. 

 

Figure 18: Changing Board Shape 

My final shape can be seen in Figure 19. You will notice I created an outline and added dimensions of 

my board there too. This is nice for the manufacturers to verify they are creating the design in the right 

size. The lettering will not show up on your final board, but just represent an extra precaution to the 

manufacturer. To measure distances in Altium, click Alt->m and click over the length you wish to 

measure. 
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Figure 19: Board Outline 

Adding Polygon Pours 
Now we will add an important feature called a Polygon pour. This creates a large plane of conductive 

copper on one of the layers for close contacts around your board. It is recommended that you always 

create a ground poor on your board to reduce noise and to simplify layout. To create a Polygon pour, 

click Place->Polygon Pour. This can be seen in Figure 20. This will bring up a window that looks like 

Figure 21. 

 

Figure 20: Placing a Polygon Pour 
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Figure 21: Adding a Polygon Pour 

Go ahead and click the net you wish the pour to be. In our case it will be the GND net. We did not place 

traces for the ground connections because the pour will automatic cover all the same net objects. Also, 

give the pour a specific name and select the layer you wish to use, in this case, the bottom layer. The last 

important point is the settings on the top right. These represent clearance and island cut-aways. Change 

the necks of copper clearance value to 6mils or greater.  Press okay and begin to place your pour. Just 

like the traces, you can click shift->spacebar to change the type of line so you can make a diagonal, 

square, or round board edges. Connect the beginning and end point of you shape and you will see the 

finished product like that in Figure 22. You will notice that there are automatic connections to the 

ground vias, and that there is a clearance between the trace on the lower layer and the GND plane. One 

last thing to notice is that the board size was put on the outside of the outline. You should always do this 

as well as put other comments around the edges of your board that are special design comments that 

the manufacturer needs to know during building. Finally, with a pour our normal rules will not apply, 

therefore we will need to figure out how to make our own custom rules.  
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Figure 22: Final board with Pour 

Finishing the Design 
Now before submitting your design we will need to do one last test and generate the correct files for the 

manufacturer to use to build. This will involve a test on our layout to verify that our design will meet the 

manufacturers’ specifications for building the board.  

Design Rule Check (DRC) 
Design rule check (DRC) is a way to verify that your design meets standards or specifications provided by 

a manufacturer or underlying process. Running the DRC is an iterative process as you go through and fix 

your errors until your design meets the spec and becomes manufacturable. The DRC tests basic 

specifications regarding distances, trace clearances, pad clearances, and various others that when you 

perform a design rule check, it goes through your design and verifies that all of the edits you performed 

are within those tolerances. Advanced Circuits has some specifications that must be met in order for you 

to use their student special prices. A set of tolerances that meet Advanced Circuits’ student special can 

be seen on the PCB Wiki Capstone website or are listed below in the table.  In the next section we will 

show how to change the rules to the right specifications.  

Design Rule Value 

Clearance  6 mils 
Routing Minimum Width 6 mils 
Routing Maximum Width Large* 
Minimum Annular Ring 7 mils 
Hole Size Minimum 15 mils 
Hole Size Maximum Large* 
Minimum Solder Mask Sliver 6 mils 
Solder Mask Expansion 0 mils 
No slots N/A 

*=Large meaning, there isn’t a maximum, as long as it fits on your board. 
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This table is the absolute minimum that advanced circuits can do. It is highly suggested to not use the 

minimum and use larger clearance tolerances (10 mils) and larger hole size minimums. The wiki also 

has a list of suggested settings you can use. To view or change the Design rules, click Design->Rules.  

This will cause a window that looks like Figure 23 to come up. If you do a design rule check, and you 

receive errors, it is because parameter values listed in the below design rules window are larger then 

what you designed into your PCB. Below we have the example of trace to pad or trace to trace 

clearance. You can see that the minimum is set to 10mils. This field means that any trace cannot be 

anywhere closer than 10mils to your other traces or pads in your design.  

 

Figure 23: Design Rules Editor 

You can always refer back to the design rules and change other rules to fit your design. Just be sure it is 

an allowed specification, otherwise, your board will have potential errors when being manufacturing. 

Before running the design rule check, make sure you have saved all of your PCB documents.  Do not 

change any of these rules yet, so we can see an example of what they look like. 

Now we will run the design rule check. Click Tools->Design Rule Check. This will cause the window seen 

in Figure 24 to show up. 
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Figure 24: Design Rule Check 

Here you can see a list of the rules set in the Design Rules window on the left side that will be 

investigated. Go ahead and click Run Design Rule Check. Next the background of Altium will change to a 

different window as well as the following messages window will pop up seen in Figure 25, Figure 26, 

and Figure 27. 
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Figure 25: DRC Error Messages 

 

Figure 26: DRC Verification Report (1/2) 
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Figure 27: DRC Verification Report (2/2) 

Figure 27 is just the same verification report as Figure 26, but scrolled down. You can see some of the 

values have errors in our design. If you click on the Green links listed in Figure 27, they will show you 

where the error is on your PCB. Go ahead and click on the top error and it should show you something 

like the following picture in Figure 28. 
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Figure 28: Silkscreen Over Component Pad 

This specific error is showing you that the minimum distance required by our design rules for silkscreen 

to pad distances is violated. While the silkscreen doesn’t overlap the pad, it is within 10 mils. This error 

can be neglected or the minimum silkscreen to pad design rule can change to accommodate this.  One 

thing to note is for advanced circuits Minimum Soldermask Sliver errors and rules do not matter. Go 

ahead and ignore these and set the minimum size of this rule to 0 mils. 

Adding Custom rules – Polygon Pour Clearance 
When you place a polygon pour, you need to make a special clearance rule from the pours to the 

component pads, traces and vias. To do this click Design->Rule Wizard.  A window like Figure 29 will 

pop up. In this window click next and a new window like Figure 30 will pop up. In this window select the 

type of rule you would like. In our case it’s a clearance rule. Give it a comment and a name (Ex. 

Polygon_clearnce). Click next and another window like Figure 31 will pop up. In here you can see all the 

types of clearance rules you have and their default values. 

 

Figure 29: Design Rule Wizard 
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Figure 30: Clearance Type 

 

Figure 31: All Clearance Rules 

Finish clicking through these menus and then you will see the PCB rules window pop up. The last thing 

we need to change is what the rule will affect. You can click Query builder to find the different types of 

components or objects your rule can affect. In our case we want the first object to have an advanced 

Query of “InPolygon” and a second object of “ISTrack OR ISVia”. Then change your polygon clearance to 

be something like 20 mils to see its affects. A finalized version can be seen in Figure 32. Design rule 

checks will be addressed in more detail in the next section. 
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Figure 32: Custom Altium Rule 

More extensive errors can occur then this, and this is a great tool to help you check your design because 

it will tell you if you have create a short circuit, forgot to connect components, or much more. Now that 

we have a design that works and fits our manufacturer’s specifications, we will generate the files needed 

for board manufacturing called Gerber and NC Drill Files. 

Creating Gerber and NC Drill Files 
After we have fixed all of our DRC errors, there are two types of files we need to generate for our 

design. The first are called the Gerber files, which are a collection of the different layers and the designs 

that make up those layers. The second are the NC Drill Files which contain information regarding 

holes/vias that are drilled through the board. Before we create them, it is important you have done a 

design rule check and verified that your footprints match your real components size.  See the Capstone 

Wiki section, Printing PCB to Scale. 

 

To create the Gerber files click Files->Fabrication Outputs->Gerber Files. This is seen in Figure 33. 

http://ecee.colorado.edu/~ecen4610/wiki/index.php/Printing_PCB_to_Scale
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Figure 33: Generating Design Files 

After selecting the Gerber Files option, a Window like that seen in Figure 34 will pop up. Go ahead and 

switch to the layers tab in the Gerber setup menu. Click all of the layers except Top Pad Master and 

Bottom Pad Master.  Also do not click any of the boxes in the Mechanical Layers(s) to add to all plots 

menu. You do not want to add any mechanical layers to your Gerber files.  Press OK and a CAM File is 

generated then Save it in the Projects Output folder within your PCB project folder.  
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Figure 34: Gerber File Setup 

Now we will generate the NC Drill Files. Click Files->Fabrication Outputs->NC Drill Files. This will cause 

the window seen in Figure 35 to pop up.  Click ok and your Drill files will show up. Save them in your 

projects output folder within your main project folder.  
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Figure 35: NC Drill Files 

This collection of files will be used to send to the device manufacturer. Once generated, save them in 

the in the “Project outputs” within your main PCB project.  

Free DFM Check 
Before we submit the board to Advanced Circuits to be etched and routed, they require that you 

perform a Free DFM check. Go to the website: http://freedfm.com/. This is a product of Advanced 

http://freedfm.com/
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Circuits. There is another link to this on the advanced Circuits website: http://4pcb.com/. A picture of 

this website can be seen in Figure 36. 

 

Figure 36: FreeDFM Website 

The first step to doing a Free DFM check is to compress the files into a .zip format. Go ahead and create 
a unique zip filename and include the NC Drill and Gerber files from your project output folder. Next, 
click upload zip File. Now a page will load that has a lot of selection options. The first section is seen in 

Figure 37.   

 

Figure 37: Submitting a PCB (1/3) 

http://4pcb.com/
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On this menu you will need to set your files to equate the correct file type so go through the list setting 
them to be the right type. The table below shows this. 
 

.DRL NC Drill  .GKO Drawing/Other 

.GBL Bottom Copper  .GTL Top Copper 

.GBO Bottom Silkscreen  .GTO Top Silkscreen 

.GBP Drawing/Other  .GTP Drawing/Other 

.GBS Bottom Soldermask  .GTS Top Soldermask 

 

After adding the correct selections in that menu, the next section is seen in Figure 38. 

 

Figure 38: Submitting a PCB (2/3) 

There are some confusing things in this section. Fill out the form to include the following items: 

 ‘Layers” -> 2 (if you are doing a 2 layer $33 special) 

 “Finish plating” -> Lead Free Solder 

 “Copper weight” (inner and outer) -> 1 oz 

 Gold Fingers -> None 

 Make “Solder Mask Sides” -> Both Sides 

 “Solder Mask Color” -> Green 

 Make “Silkscreen Sides” -> Both Sides 
Then there will be a bunch of options that you should leave blank until you get to the board dimensions 

portion of the upload. Enter in the correct Dimensions in the X-Y dimensions. The final information you 

will need to enter is the Company name, your name, and phone number. Be sure to put the University of 

Colorado. This next section can be seen in Figure 39.   
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Figure 39: Submitting a PCB (3/3) 

Submit your design wait for an email back from Advanced Circuits. This usually takes a few minutes to an 

hour depending on how busy they are. They will email you any problems with your board and you can 

talk to their technical support to find out more specifics of what may be wrong. Sometimes there might 

not be errors at all and their DRC software failed. When this happens or you believe there was an error 

in their analysis, go ahead and give them a call to verify that. 

Submitting your Design to Advanced Circuits 
After your Free DFM check completes and has no errors we will submit to advanced circuits. In a 

browser window, go to the website:  http://www.33each.com/. Upload the same .zip folder that you 

used for the Free DFM check if it came back with no errors and submit in the same fashion you did at 

the 33each website. All the options and setting you did in the FreeDFM stages are the same for normal 

submission so replicate them, and click submit. You have now ordered your first board! Wooohooo!  

 

 

 

 

 

http://www.33each.com/

